Updated scripts will be needed